The Echolot pinger at *VICTOR* echolot.virebent.art (https://echolot.virebent.art) is operational again.
The outage was caused by a stale PID file left behind . The PID file now lives under /run, preventing it from surviving reboots.
The systemd service was also improved with proper network ordering, an explicit working directory, and automatic restart on failure.
best regards
Gabx
--- Digital Signature --- q07/u5Qi6Fqlk2tG8SONB5qO7rDtiCVqYIdVdTsItdZcgogoCr9k3y7NyFZ88Cy2bvDrw1nbHPTbcvEpHxxADQ==
That sounds like it's made by inexperience programmers. It's much
better to flock() the pidfile, and then it doesn't matter if there's a
stale one left behind.
The locking will just succeed.
| Sysop: | Gate Keeper |
|---|---|
| Location: | Shelby, NC |
| Users: | 940 |
| Nodes: | 20 (0 / 20) |
| Uptime: | 497134:18:16 |
| Calls: | 15,890 |
| Calls today: | 15 |
| Files: | 5,345 |
| D/L today: |
4 files (8,192P bytes) |
| Messages: | 680,468 |